2009-11-04

以下のサイトのスクリプトをいただいて携帯メールへの通知を実装してみました。一応うまく動いてるっぽいです。途中以下のような原因不明のエラーにかなり悩まされました。結局gemのライブラリのバージョンの問題だったようだけれども・・・まだはっきりいってよくわかってません。

require 'rubygems'
require 'twitter'
require 'twitter/console'
require 'json'
require 'time'
require 'yaml'
require 'tmail'
require 'tlsmail'

色々試した結果、gem(‘twitter4r’,’0.3.1′)を上に持っていくとエラーが出なくなりました。

require 'rubygems'
gem('twitter4r','0.3.1')
require 'twitter'
require 'twitter/console'
require 'json'
require 'time'
require 'yaml'
require 'tmail'
require 'tlsmail'

うーん?gemでバージョンを指定すると、その後のrequire文もその影響を受けるんですかねぇ?

コメントを残す